Slitaz remade & @85% needs work

This board posts about running linux on your webdt366
Post Reply
quotaholic
Administrator
Administrator
Posts: 569
Joined: Tue Mar 24, 2009 9:11 pm

Slitaz remade & @85% needs work

Post by quotaholic » Mon May 18, 2020 12:34 pm

Ive spent a few weeks working with Slitaz v3 on the DT366GX series. ron85 has a YouTube video where he mentions purchasing from tbowland which means its an lx800 series and 512mb ram and faster board than gx series can offer. Lx800 usually means WebDT360 model. That being said I have this somewhat working on DT366GX. I think I have a bad flash chip and wish this off as I made the iso in VM and hope that it can work for anyone looking. I cant get certain things to work but possibly you can without bad flash chip?

Slitaz is neat as it has Tazlito, a utility that can take their compressed package files (much like slax extensions) back in the day and it will install it to a rootfs folder and compress it. Then it ties in kernel and boot loader and makes an iso file one can install from. I hear this is a fork of dsl linux or damn small linux. When making this image I used the core flavor and removed a great number of applications. Some menu items may not work. I did not remove them from being listed in the menu. My thoughts are to make a live install as small as possible. Since Slitaz has package manager and a way to save changes I am mostly concerned with core hardware functionality. Software is user centric. AKA please excuse icons that do not work. There is a red X on the LXDE panel. If you install a web browser it will turn in to an icon.

This is really old hardware. As such we need an old boot loader to make an iso on usb work on this tablet. Use lili linux loader version 2.0 here:

http://download.tuxfamily.org/lilicreat ... %202.0.zip

If you use newer versions the boot will hang at first line.

Lili will run like a portable app and not install. On the 3 check boxes at the bottom change each one. Number two needs to be selected and one and three unselected.

Now the iso file. First I will present it, then add all the instructions. Warning if you watched the movie, Dr. Strange, the warnings come after.

Needed hardware:

Passive usb hub and a rf keyboard with usb 2.0 dongle.
or
Powered usb hub if using usb corded keyboards

2 usb sticks that are 2gb (best success) and the attached iso file

Prepare USB

Once you use windows and lili to load the iso file to use plug it in to hub and boot webdt. If usb is not first on your boot order you won't boot to usb. Hit F1 until you get a green bios screen and figure out how to change boot order to usb hd or USB Stick first.

How to boot

On the Slitaz splash screen you need to type and you need to press a letter within 30 seconds to stop the boot. If not you will look at what looks like broken graphics. We need to tell linux kernel to boot at a lower resolution and to let us configure the graphics or go in to text mode. Issue:

Code: Select all

slitaz vga=788 screen=text lang=C kmap=us
And in two to three minutes you will see a login prompt. Use:

Code: Select all

root
for username

Code: Select all

root
for password


First step install to HDD

Insert 2nd usb holding iso file
watch output and see if it is sdb... if so:

Code: Select all

mount /dev/sdb1 /mnt

Code: Select all

ls /mnt
and see if iso file is there.

If so:

Code: Select all

mkfs.ext3 /dev/hda1
and wait for it to finish

Install image to HDD

Code: Select all

tazusb gen-iso2usb /mnt/slitaz-core3-webdt-2.4.iso /dev/hda1
When it finished reboot and when screen goes black pull both drives. Wait 2 minutes... When the screen shows the Slitaz splash screen again type:

Code: Select all

slitaz vga=788 screen=text lang=C kmap=us home=/dev/hda1
That will get us booted from installed hdd and to a text prompt.

Touchsrceen

Now lets get the touchscreen working.

Code: Select all

pm-setup -s
and let it finish. It will sniff your ts hardware and make a config file yet to be filled.

Now lets copy the graphic config file in to place:

Code: Select all

cp /root/xorg.conf /etc/X11/xorg.conf
Now lets start the login manager as root (seems to be needed Slitaz step to setup properly....?)

Code: Select all

slim
When the desktop starts it will complain about not having an icon theme and wallpaper is missing. To fix open menu in lower left and in preferences font Gtk preferences and wallpaper settings. In these two let window manager take care of desktop icons with one checkbox and in the other section choose the icon tab and go for the 2nd tango icon theme. Apply each and ext both.

Lets calibrate screen. Open terminal:

Code: Select all

gCal 9
. will start the calibration utility with 9 cal points to touch. Go one to the next until it completes touching each.

Code: Select all

gPen
will open a settings util for the TS. Go to settings tab and check the circle for "mouse mode". Close. Now config file has been populated and touchscreen should work well on next boot.

Prepare for next boot

Code: Select all

cd /root

Code: Select all

cp extlinux.conf /home/boot/extlinux.conf

Code: Select all

nano /home/boot/extlinux/extlinux.conf
and change any UUID for home= to home=/dev/hda1 *sorry one file got away from me

Code: Select all

cp /root/isolinux.cfg /home/boot/extlinux

Code: Select all

nano /home/boot/extlinux/isolinux.cfg
and make sure home=/dev/hda1 just to be safe.

Now next time we boot we will not need to type anything until we are loaded to ram.

Save changes for next boot!

Your touchscreen should work well now. If you want to do a preliminary save please use:

Code: Select all

tazusb writefs gzip /dev/hda1
This will take 30+ minutes but will move the current /home/boot/rootfs.gz you booted to and change it to previous.gz. The current filesystem you are using will be written as /home/boot/rootfs.gz and that is what you will boot to next boot. This being said see caveats section before you add software!

Slitaz is not working well with regards to auto login. AT least with my hdd giving superblock errors. Or I am just not seeing clear solution.

We want to copy the files of /root/xsession and /root/xbindkeysrc to home and root directories as hidden files with:

Code: Select all

cp /root/xbindkeysrc /home/tux/.xbindkeysrc

Code: Select all

cp /root/xsession /home/tux/.xsession

Code: Select all

cp /root/xbindkeysrc /root/.xbindkeysrc

Code: Select all

cp /root/xsession /root/.xsession
Now ownerships

Code: Select all

cd /home/tux

Code: Select all

chown tux .xbindkeysrc

Code: Select all

chown tux .xsession
and repeat for any other users you add

You will also want to startx from each users directory in order to auto place an ~/.Xauthority file in each user(s) dirs. I find that Xorg states no protocol and fails to allow starting when these files are not in place, not with the correct permissions. Xlib no protocol errors. PITA to diagnose!

I have a few utilities installed that may be useful including xdotool as well as xvkbd. I cant get xvkbd to work again after I made it work once before. xbindkeys will sniff out key codes from buttons and help you reassign them to either other keys or launching programs. the settings files are in the users directories and they are called .xbindkeysrc. See caveats section for more!

Many images ago I took fonts from fedora 10 running in vm. Copied them out on usb and manually inserted them in to slitaz and installed mkfontdir and mkfontscale. These items came from slitaz 5 and I ran them once in each dir that I made. /usr/share/fonts/X11/75dpi and /usr/share/fonts/X11/100dpi.

After this I uninstalled the mkfontscale and mkfontdir from version 5 as this is version 3 and that one time xvkbd worked. I feel that as I included these within the image this may be the cause of xvkbd not working. So I also include cellwriter that can start as a on screen keyboard.

The geode video driver works well and I think you will be impressed with screen responsiveness. In the root directory there are some things I was working on that I could not get to work well. Please feel free to continue my work. Tazpkg is the package manager and it can convert packages from other distributions. It is like alien from Slackware days. deb-rpm can be converted to compressed Tazpkg.


Caveats and things I cant get to work correctly

Again this is a custom kernel. If you upgrade this kernel that is installed it may result in loss of functionality. This hardware is so old that much of it is in "deprecated" sections of the linux kernel. Thus mainstream linux no longer supports. I built in the Audio in to the kernel. Run

Code: Select all

alsamixer
and you will see only one audio option and settings for.I believe Tazpkg has the ability to lock a package at a version. Please look in to this.

I felt that I almost had auto login working when I added new user and adjusted the following files to represent:

/etc/slim.conf
/etc/rcS.conf

and of course pay attention to the ownership of .xsession .Xauthority .xinitrc and so forth.

Code: Select all

tazctlbox
is kind of a multi tool for configs in slitaz. Look within as its almost all here including wireless networks, who gets to auto login and what daemons or modules to start or mod probe at boot.

Code: Select all

tazx
is supposed to be run by a user and make it possible for them to autologin. Its not going to rewrite Xorg.conf!

All of these inter-relate and somehow allow autologin for a user. Not root. Don't even try it. If you think I am joking look at /etc/init.d/rcS

Its ugly. Its slitaz. Feel free to ask them how to get it to work. I merely rebuilt kernel and added packages to get tablets working. That being said keep an RF keyboard around. This is the fastest thing I have seen on this hardware but I just cant get it to work properly.

Buttons:

atlas_btns is the kernel module that makes them work however depending on when they are activated in the boot process I notice that they sometimes do not work. I am still seeking the proper place to mod probe these so that they get in to the /dev/input/eventx listing. As current they go to sysfs as /devices/virtual and ket mapped as keyboard with no key codes being sent on button press. I know that we can put the mod probe actions in to:

/etc/rcS.conf
/home/$USER/.xsession

and even syslinux boot line as modprobe=mod1,mod2,mod3

This would be in:

/home/boot/extlinux/extlinux.conf

and

/home/boot/extlinux/isolinux.cfg


Biggest Caveat and also best feature: Geode video driver won't exit cleanly from x:

This version of linux supports ctl+alt+bkspc for killing the server. When running geode video driver don't do this....

As I said. Still working on this. You will find that you won't want to kill the X server once its running on the geode driver. Just switch TTY's with ctl+alt+Fx

then run top and find the pid that X is running on. q to quit top and:

kill # of PID

like:

Code: Select all

kill 1227
for example. Otherwise you will have to hit ctl+alt+delete and hope it reboots otherwise if you hold power button down to manually power down you may corrupt the filesystem. Or I just have a really bad flash. Any ways. I built this in vm on a newer iMac. Not my tablet. I took notes and this is as close as I can get. Hopefully you get further. If I make any strides I will share my rootfs.gz from here out as it will be easier to copy in to place after install, I just cant guarantee it won't carry my tablets problems with it.

Things I know...

The right side button won't send a key code. This button will send a scan code. Make an entry to the keysym var db for all key codes to get this button to convert to a scan code. In the past I have tried setkeycodes to do this but it did not work. Once it makes a key code we can use xmodmap or xbindkeys to make it do something else. This button can be seen with app od if its modprobed at the right time. Meaning it needs to be in /dev/input/eventx
Again at current I cant find the right place to mod probe this to get it to work as expected and as long as I cant get autologin to work it is hard to justify the time. If users want a great linux to use on eBay tablets like these try this but expect to get a new wifi card as this tablets stock Cisco card only supports wireless b networks as well as wep encryption. I know it says wpa supported in init, trust me. It won't. Not unless you extract the driver from the linux mce image that was also aimed at this hardware but then you are still wireless b. Get a wireless g pcmcia card as well as an rf keyboard and you will have an okay experience with this tablet. Slitaz offers opera version 1 for this and one can install mplayer from menu item as well. This os is 8 years old.

Remember to save!

Code: Select all

tazusb writefs gzip /dev/hda1
is your friend only notice that a buildup of old files starts to pile up on hdd.

Code: Select all

tazusb clean
is interactive and will help you keep hdd tidy. Run this each time you save. LXDE offers to save for you but this only works when all users have proper X files in directory and with proper permissions.

Newer versions of slitaz won't produce a gui on screen for me. It looks promising but I just cant get an error or a screen that activates.No indications why no gui is working. Only top indicating X is running with no VT associated. So for now we have old slitaz that works great with an rf keyboard.

acpitool can be converted from ubuntu or Debian repos and may help one get suspend working. In my experience I could not get tablet to wake up with these converted packages.

Punchlist to get functional


Need to initialize the button controller (atlas_btns) at a time of init that allows it to be seen by xbindkeys. Once atlas_btns sends key codes xbindkeys (for front hard buttons) can launch programs and a /home/$USER/.Xmodmap file can aim the d-pad at arrow actions easily.

Need to get autologin working.

Try to get xvkbd working. I feel that slitaz on usb is not that supported. I installed with Syslinux. Cant imagine why grub would make a difference but its there if anyone wants to try. xdotool can be used to map xvkbd quickly. Lookup xdotool in the search on this forum for a script on how.

Last but not least get a way to map a scan code to a key code for the invisible right side button. Only utilities I have found that can read it are od and evtest.
Attachments
slitaz-core3-webdt-2.4.iso.zip
(26.96 MiB) Downloaded 210 times

Post Reply